Wordpress 2.5.1 Borked Maintenance Mode

I was going to write a nice blog post during lunch today, but I ran into some issues which I had to spend the time fixing instead.

Before I did the upgrade, I enabled Maintenance Mode.

Then I did the upgrade.

Then I couldn’t do anything.

None of the pages which I tried to go to, including upgrade.php and wp-admin, would load. All of them gave me Maintenance Mode messages. Now that I look at the plugin page, it seems it was only compatible up to version 2.3 of WordPress…


So I had to figure out how disable a Wordpress plugin manually. A bit of mysql command line and php deserialize and serialize later, I was back up, with my lunch hour all but completely consumed.

So here’s my post for the day, much later and probably less interesting.

blog comments powered by Disqus